Student Data Visibility Issue
Resolved
Oct 30 at 07:42pm MST
We have addressed the issue, and we are entirely back online.
Affected services
Updated
Oct 30 at 06:00pm MST
We have implemented a fix and are currently conducting testing. We have applied a fix and are currently testing it.
Affected services
Created
Oct 30 at 03:30pm MST
We are currently experiencing an issue with student data visibility in Manager, Math, and Studio, which may impact student logins. Our team is actively investigating and working to resolve the issue. We will provide updates as they become available.
Affected services