Back to overview
Degraded
Account Page Slowness
May 06 at 06:00am MST
Affected services
MindPlay Account
Resolved
May 06 at 10:16am MST
The Account back is back to normal.
Affected services
MindPlay Account
Updated
May 06 at 09:43am MST
We have identified the problem and pushed a fix. We are continuing to test and verify that all issues have been resolved.
Affected services
MindPlay Account
Created
May 06 at 06:00am MST
We are getting reports that our Account is running slowly. This may be causing issues with logging in or just taking time to load once logged in.
Our engineering team is looking into it.
Affected services
MindPlay Account